Fluval Edge Filter Noise

View previous topic View next topic Go down

Fluval Edge Filter Noise

Post  Malcolm on Sat Jul 24, 2010 6:17 pm

I have just set up my Fluval Edge (no fish yet). Beautiful looking tank but it is totally let down with the filter pump sound as it is annoyingly noisy. I have removed the top cover of the filter unit and it is quieter but still unacceptably noisy. I have taken the whole thing apart and reassembled but still the noise persisits. The pump obviously has to run continuously but with this constant noise its not something I want. Unless the noise can be surpressed I will not be stocking with fish and I may well reconsder my purchase. Does anyone have any advice on what to do about the noisy filter pump. Thanks

Malcolm
Neon Tetra

Posts: 2
Join date: 2010-07-24
Location: Scotland

Back to top Go down

Re: Fluval Edge Filter Noise

Post  MrGator on Sat Jul 24, 2010 8:24 pm

Hi Malcolm, welcome to the fluval edge forums!

I must admit, when I first started up my edge, I was a little perturbed by the noise that came from the filter and the vibrations on the filter cover were enough to make me reconsider my purchase too. However, I was told by a friend who also had one that the filter noises subside once the filter has been run for a week or two - I was a bit cynical as I'm sure a filter should operate with the same noise levels from when it's first used until it's ready for the knackers yard - but I gave it a go and it worked!

The only noise I now have coming from the filter is the stream of water - it's virtually silent.

If however, the filter does continue to make noises, you can either write to fluval or take the filter back to the shop where you purchased it and they should replace it for you.

I also had a bit of trouble with the impeller coming unseated and the filter not working, but a poke with a screwdriver pops it back into place - I actually took mine back to Pets @ Home and they did it for me - it happened once since and I sorted it myself.

My advice would be to stick with it, they're a gorgeous tank and I'm really looking forward to seeing some pics from you as your tank matures!

Sean What a Face

MrGator
Angelfish

Posts: 71
Join date: 2010-07-01
Age: 31
Location: London, UK

http://www.fluvaledgeforum.co.uk

Back to top Go down

Re: Fluval Edge Filter Noise

Post  Malcolm on Sat Jul 31, 2010 9:03 am

Many thanks for this advice. I have now left the tank for a week and the noise level has reduced considerably, although not completely gone. At least it is now bearable! Hopefully another few days will see to it being silent.

Cheers,

Malcolm
Neon Tetra

Posts: 2
Join date: 2010-07-24
Location: Scotland

Back to top Go down

Also bad noise

Post  Max on Sun Jan 30, 2011 11:53 am

Hey guys!

It is day 4 or my edge running, and the filter has been terribly noisy from the first startup. I have tried a number of things, and nothing helps so far. If time will fix it, I can only imagine that it is a poorly cut piece on the impeller or that piece of plastic between the intake and the impeller that will eventually wear down.

If it doesn't fix itself, I may try putting some O-rings under the magnet. Another thing I may end up trying is sanding down a few of the possible problem pieces, ever so slightly.

How is your pump noise coming along, Malcolm?

Cheers,
Max

Max
Pygmy Cory

Posts: 12
Join date: 2011-01-30

Back to top Go down

Re: Fluval Edge Filter Noise

Post  Deborah on Sun Jan 30, 2011 12:39 pm

I'm probably stating the obvious but do ensure that the HOB is full of water before running the filter.

Deborah
Guppy

Posts: 5
Join date: 2011-01-30
Location: Buckinghamshire

Back to top Go down

Re: Fluval Edge Filter Noise

Post  Max on Sun Jan 30, 2011 3:48 pm

Yes, I have always had the filter totally full when starting it up. Then it primes the intake which is extra noisy, with all the bubbles, and when that is over, it runs like a little diesel engine.

Max
Pygmy Cory

Posts: 12
Join date: 2011-01-30

Back to top Go down

Re: Fluval Edge Filter Noise

Post  ninjaguy on Tue Feb 01, 2011 4:56 pm

Max,

It took quite a few weeks for my pump to quieten down, now it is near silent.
I also noticed a rattling coming from the plastic lid above the filter media. I saw some suggestions about removing it, but this cause extra evaporation.
In the end I left it on, but slightly twisted, it's quite now.

Regards,

Colin

ninjaguy
Betta

Posts: 15
Join date: 2010-09-11
Age: 46

Back to top Go down

Re: Fluval Edge Filter Noise

Post  Max on Tue Feb 01, 2011 5:16 pm

Thanks for that Colin. I'm glad to hear another account of the noise fixing itself. I was taking a closer look at it yesterday, and I'm now pretty confident that the noise comes from the fact that the impeller has maybe 2 or 3 millimeters of free play vertically on the shaft, if that makes sense. If it moves down, the impeller wings can grind a little on the little ledge below the wings. Anyways, we'll see if I can just be patient and let it work itself out.

Oh, and I've left off the filter cover off the whole time. Sounds like a train station if I put it on.

Thanks again.

Cheers,
Max

Max
Pygmy Cory

Posts: 12
Join date: 2011-01-30

Back to top Go down

filter noise

Post  Alastair on Sat Feb 05, 2011 4:37 pm

Hi to all. (First post!)
Read a lot about filter noise. Had my tank 4 weeks. Filter does buzz a wee bit, but minimal with filter lid off and unit tweaked to best position. Try wee bit of blu tack where filter rests on edge of tank. Was told nano tanks are harder for a beginner to start with. Seems true - I had white spot and mortalities in first 2 weeks! However, tank has now cycled. 3 guppies, 3 tetras and a sucking loach. All happy now. A small live plant helped matters too. It's a thing of beauty! So, if you want help with cycling details, sick fishies or feeding the wee skitters during your early days, be happy to try to help!
Alastair

Alastair

Posts: 1
Join date: 2011-02-05

Back to top Go down

Re: Fluval Edge Filter Noise

Post  Serge on Thu Dec 22, 2011 10:21 pm

I've solved the problem!!!!

Initially the impeller can rotate on 180 deg around magnet. If you'll stick (glue) it the noise will disappear forewer.
The result will be better if you make them much more concentric!

Serge

Posts: 1
Join date: 2011-12-22

Back to top Go down

Re: Fluval Edge Filter Noise

Post  pollewops on Fri Jun 15, 2012 7:00 pm

I bought mine Edge 46L 2 weeks ago and also my filter was noisy....
Removing the lit did solve some, but still noisy.....

After removing the motor and remove the propeller I put some vaseline on the axe and put everything together again.
After that.....silence !!!!! real silence !

I am happy now :-)

pollewops
Neon Tetra

Posts: 3
Join date: 2012-06-15
Age: 48

http://www.pollewops.nl

Back to top Go down

Vaseline saves my ears

Post  annesaxo on Thu Aug 09, 2012 9:30 pm

Thanks very much for the tip about vaseline. Had my edge for about 4 months and never had any problems with noise until last few weeks. The filter has recently started making a terrible noise, tried taking it apart several times and washing all the parts but nothing worked for long. Put vaseline on the propeller and the pin plugged it back in and silence just like you said. So anybody having trouble with noise that isn't just vibration try vaseline it really works.

annesaxo

Posts: 1
Join date: 2012-08-09

Back to top Go down

Re: Fluval Edge Filter Noise

Post  jwebbe on Thu Aug 09, 2012 10:49 pm

Seems to be an ongoing problem with the fluval filters. I had the same thing happen to me twice now and my tank is only 2 months new. The vasoline trick did the trick for me but I think I am going to get some real lubricant stuff that won't wear off as easily. Seems like 2 times in that short of time indicates that the vasoline wears off too quickly.


jwebbe
Otto

Posts: 25
Join date: 2012-06-26
Location: Northern California

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

Permissions in this forum:
You cannot reply to topics in this forum