Used Fluval Edge Filter - Noise

View previous topic View next topic Go down

Used Fluval Edge Filter - Noise

Post  Bhillison on Mon Nov 01, 2010 5:31 pm

Hi All,

New here so hope I get the format right !!!

Bought a used Edge and instantly noticed the noise levels of the filter unit.
Have left the lid off and has made a huge difference but not enough.
I know previous threads here say the noise settles but does that apply to used filters or only new ones.
Before I set it all up though, I did take everything possible apart and give it a good clean.
Boy the previous owner neglected it, found strands of plastic inside the impeller shaft....
I do however like the sounds of the falling water, reminds me of being outside.........Boring, yes I know.

But what amazed me was I bought this for £50, 30 mins after being on, lights went out. Bulbs didn't blow, it was the transformer, noticed then previous owner replaced bulbs with 2 20w bulbs which meant transformer overloaded. Spoke with seller and she was the most kindlest seller I've ever met. Agreed to buy a brand new light unit (comes as a whole) and post it to me as she said it was her responsibility to sort it.

Now, don't you wish ALL sellers of all kinds were like that......?

Anyway, back to the topic......If anyone knows about a used filter quietening down, please let me know.....

Bye for now.

Bhillison

Posts: 1
Join date: 2010-11-01

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

Permissions in this forum:
You cannot reply to topics in this forum